What’s Vulnerable › Vulnerabilities
CVE-2026-14225: Easy Appointments < 3.12.28 - Contributor+ Shortcode Allowlist Bypass
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-20
Description
The Easy Appointments WordPress plugin before 3.12.28 does not correctly validate shortcode input in one of its block-rendering actions, checking only the first tag of the supplied string against an allowlist while rendering the entire string, allowing users with contributor-level access to execute arbitrary registered shortcodes.
Affected products
- Easy Appointments: before 3.12.28 — fixed in 3.12.28
How to fix
Upgrade to a fixed version: Easy Appointments 3.12.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14225 or the next vulnerability affects your stack