What’s Vulnerable › Vulnerabilities
CVE-2026-14229: ECS < 4.3.8 - Unauthenticated Private Content Disclosure via ecsload
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-15 · updated 2026-08-26
- Weakness: CWE-284
Description
The ECS WordPress plugin before 4.3.8 does not check the post status or any capability when rendering an Elementor document requested through one of its AJAX actions, allowing unauthenticated users to retrieve the rendered content of unpublished (private, draft, pending) documents by supplying their identifier.
Affected products
- ECS: before 4.3.8 — fixed in 4.3.8
How to fix
Upgrade to a fixed version: ECS 4.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14229 or the next vulnerability affects your stack