What’s Vulnerable › Vulnerabilities
CVE-2026-14230: ECS < 4.3.8 - Contributor+ Stored XSS via Dynamic Repeater Bindings
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-15 · updated 2026-08-26
- Weakness: CWE-79
Description
The ECS WordPress plugin before 4.3.8 does not perform capability or object-ownership checks on its Dynamic Repeater AJAX handlers (gated only by a capability-agnostic nonce that any edit_posts user obtains from the Elementor editor), so a Contributor can write a data-source binding into any post — including admin-authored pages — whose attacker-controlled values are rendered into a widget's repeater output without sanitization, executing JavaScript in the session of any visitor or administrator who views the page.
Affected products
- ECS: before 4.3.8 — fixed in 4.3.8
How to fix
Upgrade to a fixed version: ECS 4.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14230 or the next vulnerability affects your stack