What’s Vulnerable › Vulnerabilities
CVE-2026-14239: Tourmaster < 5.4.8 - Stored XSS via CSRF
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-08-04
- Weakness: CWE-79
Description
The tourmaster WordPress plugin before 5.4.8 does not perform a nonce check when storing a custom-filter label taken from a request parameter, and does not escape that label when echoing it on the filter admin page, allowing an unauthenticated attacker to trick a logged-in administrator into storing JavaScript that then executes in the admin area (stored Cross-Site Scripting via CSRF).
Affected products
- tourmaster: before 5.4.8 — fixed in 5.4.8
How to fix
Upgrade to a fixed version: tourmaster 5.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14239 or the next vulnerability affects your stack