What’s Vulnerable › Vulnerabilities

CVE-2026-14288: Use of Incorrectly-Resolved Name or Reference in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.4 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated to bypass a required merge request approval policy on a protected branch due to improper access control during approval rule synchronization.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.3.6, 19.4.3; GitLab 19.3.6, 19.4.3, 19.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14288 or the next vulnerability affects your stack