What’s Vulnerable › Vulnerabilities
CVE-2026-14307: Geotargeting WP < 3.5.6.2 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-30 · updated 2026-08-31
- Weakness: CWE-79
Description
The geotargetingwp WordPress plugin before 3.5.6.2 does not sanitise or escape several parameters before reflecting them back in AJAX responses that are served with an HTML content type, allowing unauthenticated attackers to inject arbitrary web scripts that execute when a victim is tricked into submitting a crafted request.
Affected products
- geotargetingwp: before 3.5.6.2 — fixed in 3.5.6.2
How to fix
Upgrade to a fixed version: geotargetingwp 3.5.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14307 or the next vulnerability affects your stack