What’s Vulnerable › Vulnerabilities

CVE-2026-14341: Missing Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an authenticated user with Maintainer role to modify protected branch configuration due to improper authorization in a projects API endpoint.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.5, 19.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14341 or the next vulnerability affects your stack