What’s Vulnerable › Vulnerabilities

CVE-2026-14344: Inconsistent authorization checks in Mattermost Boards endpoints

Description

Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to enforce the board-creation permission which allows an unauthorized authenticated user to create boards via the board duplicate, boards-and-blocks, and archive-import endpoints.. Mattermost Advisory ID: MMSA-2026-00715

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.23, 11.7.8, 11.8.5, 11.9.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14344 or the next vulnerability affects your stack