What’s Vulnerable › Vulnerabilities
CVE-2026-14470: Langflow OSS is affected by arbitrary file read due to path traversal vulnerabilities in file and knowledge base components
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-10
- Weakness: CWE-22
Description
IBM Langflow OSS 1.0.0 through 1.10.2 could allow an authenticated attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot" sequences (/../) to view arbitrary files on the system.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.3 — fixed in 1.10.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14470 or the next vulnerability affects your stack