What’s Vulnerable › Vulnerabilities

CVE-2026-14521: IBM DataPower Gateway affected by server-side request forgery

Description

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating other attacks.

Affected products

How to fix

Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 10.5.0.23, 10.6.0.11, 11.0.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14521 or the next vulnerability affects your stack