What’s Vulnerable › Vulnerabilities
CVE-2026-14558: WP User Frontend < 4.3.10 - Editor+ PHP Object Injection via AI Form Builder
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-08-28
- Weakness: CWE-502
Description
The User Frontend WordPress plugin before 4.3.10 does not properly validate field type definitions and deserialises user-controlled post metadata when rendering submitted posts, allowing users with Editor-level access and above to inject arbitrary PHP objects, which can lead to remote code execution when a suitable POP chain is present on the site.
Affected products
- User Frontend: before 4.3.10 — fixed in 4.3.10
How to fix
Upgrade to a fixed version: User Frontend 4.3.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14558 or the next vulnerability affects your stack