What’s Vulnerable › Vulnerabilities
CVE-2026-14620: webpack-dev-server vulnerable to cross-site request forgery via internal developer endpoints
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-03 · updated 2026-07-07
- Weakness: CWE-352
Description
webpack-dev-server versions 5.2.5 and earlier expose two internal developer endpoints, /webpack-dev-server/open-editor and /webpack-dev-server/invalidate, that perform state-changing actions on any GET request without verifying that the request originated from the dev server's own page. Any website a developer visits while the dev server is running can trigger these endpoints cross-origin with no interaction beyond the visit. An attacker can open an arbitrary existing local file in the developer's editor, including files outside the project root, and repeated requests can spawn editor processes and force recompilations that degrade the developer's machine. Patches: upgrade to webpack-dev-server 5.2.6. Workarounds: none.
Affected products
- webpack-dev-server: before 5.2.6 — fixed in 5.2.6
- Npm Webpack-Dev-Server: before 5.2.6 — fixed in 5.2.6
How to fix
Upgrade to a fixed version: webpack-dev-server 5.2.6; Npm Webpack-Dev-Server 5.2.6. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/webpack/webpack-dev-server/security/advisories/GHSA-f5vj-f2hx-8m93
Get alerted when CVE-2026-14620 or the next vulnerability affects your stack