What’s Vulnerable › Vulnerabilities
CVE-2026-14631: webpack-dev-server vulnerable to denial of service via a malformed Host or Origin header
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-03 · updated 2026-07-07
- Weakness: CWE-20
Description
webpack-dev-server versions 5.2.5 and earlier terminate the whole Node.js process when an unauthenticated peer sends either a normal HTTP request with a malformed Host header or a WebSocket upgrade to the default /ws endpoint with a malformed Origin header. The malformed value causes an uncaught exception in the host-validation path and crashes the dev server. Impact is limited to availability of the development server, no data disclosure, no code execution. Patches: upgrade to webpack-dev-server 5.2.6. Workarounds: keep the dev server bound to localhost (the default) and do not expose it to untrusted networks.
Affected products
- webpack-dev-server: before 5.2.6 — fixed in 5.2.6
- Npm Webpack-Dev-Server: before 5.2.6 — fixed in 5.2.6
How to fix
Upgrade to a fixed version: webpack-dev-server 5.2.6; Npm Webpack-Dev-Server 5.2.6. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/webpack/webpack-dev-server/security/advisories/GHSA-m28w-2pqf-7qgj
Get alerted when CVE-2026-14631 or the next vulnerability affects your stack