What’s Vulnerable › Vulnerabilities
CVE-2026-14644: Nexus Repository 3 - Privilege Escalation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-09-22
- Weakness: CWE-843
Description
Nexus Repository 3 contained a privilege escalation vulnerability in the REST privileges API. An authenticated user with permission to manage privileges could, under certain role configurations, escalate their own access to full administrator by exploiting a type-confusion flaw in the privilege update endpoint.
Affected products
- Sonatype Nexus Repository 3: from 3.19.0 before 3.95.0 — fixed in 3.95.0
How to fix
Upgrade to a fixed version: Sonatype Nexus Repository 3 3.95.0. Check the vendor advisory for mitigations.
References
- https://help.sonatype.com/en/sonatype-nexus-repository-3-95-0-release-notes.html
- https://support.sonatype.com/hc/en-us/articles/53157550694675
Get alerted when CVE-2026-14644 or the next vulnerability affects your stack