What’s Vulnerable › Vulnerabilities
CVE-2026-14664: PostgreSQL regexp heap buffer overflow executes arbitrary code
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-29
- Weakness: CWE-122
Description
Heap buffer overflow in PostgreSQL regexp allows the query author to execute arbitrary code as the operating system user running the database, via text that would not pass encoding validation. This shares heritage with CVE-2026-2006, but this case involved unanticipated data growth when round-tripped through pg_wchar. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Affected products
- PostgreSQL: from 14.0 before 14.24; from 15.0 before 15.19; from 16.0 before 16.15; from 17.0 before 17.11; from 18.0 before 18.5 — fixed in 14.24, 15.19, 16.15, 17.11, 18.5
How to fix
Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14664 or the next vulnerability affects your stack