What’s Vulnerable › Vulnerabilities

CVE-2026-14669: PostgreSQL to_char heap buffer overflow executes arbitrary code

Description

Heap buffer overflow in PostgreSQL to_char(timestamptz) allows the party choosing the timezone to execute arbitrary code as the operating system user running the database, via a long POSIX timezone abbreviation. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14669 or the next vulnerability affects your stack