What’s Vulnerable › Vulnerabilities

CVE-2026-14670: PostgreSQL plperl tied object heap buffer overflow executes arbitrary code

Description

Heap buffer overflow in PostgreSQL plperl return of a tied hash allows the function owner to execute arbitrary code as the operating system user running the database, via a crafted function body. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14670 or the next vulnerability affects your stack