What’s Vulnerable › Vulnerabilities
CVE-2026-14671: PostgreSQL refint plan cache type confusion executes arbitrary code
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-29
- Weakness: CWE-843
Description
Type confusion in PostgreSQL module "refint" allows an object creator to execute arbitrary code as the operating system user running the database. The fix for this emerged as a non-security bug report, and the fix appear in the git repository with subject "refint: Remove plan cache.", without a CVE number. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Affected products
- PostgreSQL: from 14.0 before 14.24; from 15.0 before 15.19; from 16.0 before 16.15; from 17.0 before 17.11; from 18.0 before 18.5 — fixed in 14.24, 15.19, 16.15, 17.11, 18.5
How to fix
Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14671 or the next vulnerability affects your stack