What’s Vulnerable › Vulnerabilities
CVE-2026-14676: PostgreSQL pg_stat_statements heap buffer overflow executes arbitrary code
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-29
- Weakness: CWE-122
Description
Heap buffer overflow in PostgreSQL pg_stat_statements allows the query author to execute arbitrary code as the operating system user running the database, via crafted queries containing array constants. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.
Affected products
- PostgreSQL: from 18.0 before 18.5 — fixed in 18.5
How to fix
Upgrade to a fixed version: PostgreSQL 18.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14676 or the next vulnerability affects your stack