What’s Vulnerable › Vulnerabilities

CVE-2026-14678: PostgreSQL pg_trgm picksplit reads past end of buffer

Description

Buffer over-read in PostgreSQL pg_trgm index picksplit function reads past end of a heap buffer. This might allow a table maintainer to infer limited memory values, via the lossy signal of index split choices. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14678 or the next vulnerability affects your stack