What’s Vulnerable › Vulnerabilities
CVE-2026-14679: PostgreSQL stack buffer overflow in argument match writes 0x0 and 0x1 to server memory
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-29
- Weakness: CWE-121
Description
Stack buffer overflow in PostgreSQL argument name matching allows an object creator to achieve unknown impacts via OUT parameter count. The attack can write only 0x0 and 0x1 bytes. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
Affected products
- PostgreSQL: from 14.0 before 14.24; from 15.0 before 15.19; from 16.0 before 16.15; from 17.0 before 17.11; from 18.0 before 18.5 — fixed in 14.24, 15.19, 16.15, 17.11, 18.5
How to fix
Upgrade to a fixed version: PostgreSQL 14.24, 15.19, 16.15, 17.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14679 or the next vulnerability affects your stack