What’s Vulnerable › Vulnerabilities
CVE-2026-14681: PostgreSQL improper enforcement of GSSAPI encryption when coupled with SSL
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-29
- Weakness: CWE-924
Description
Improper enforcement of message integrity in PostgreSQL GSSAPI support allows a user to negotiate GSSAPI contrary to pg_hba.conf rules, via initial direct TLS connection. Despite a pg_hba.conf that appears to require GSSAPI, the connection may exchange data over TLS encryption alone. If the TLS settings are more permissive than the GSS settings, the connection may continue with lesser protection. Within major versions 17-18, minor versions before PostgreSQL 18.6 and 17.11 are affected. Versions before PostgreSQL 17 are unaffected.
Affected products
- PostgreSQL: from 17.0 before 17.11; from 18.0 before 18.5 — fixed in 17.11, 18.5
How to fix
Upgrade to a fixed version: PostgreSQL 17.11, 18.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14681 or the next vulnerability affects your stack