What’s Vulnerable › Vulnerabilities
CVE-2026-14833: Lightbox with PhotoSwipe < 5.9.0 - Author+ Stored XSS via data-lbwps-caption Attribute
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-08-26
- Weakness: CWE-79
Description
The Lightbox with PhotoSwipe WordPress plugin before 5.9.0 does not sanitise or escape a link data attribute before rendering it into the image lightbox caption in the browser, allowing users with author-level access and above (who lack the unfiltered_html capability) to store JavaScript that runs when a visitor or administrator opens the lightbox.
Affected products
- Lightbox with PhotoSwipe: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: Lightbox with PhotoSwipe 5.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14833 or the next vulnerability affects your stack