What’s Vulnerable › Vulnerabilities
CVE-2026-14834: Mailgun for WordPress < 2.2.1 - Unauthenticated Arbitrary Mailgun List Subscription via add_list AJAX
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-08-26
- Weakness: CWE-284
Description
The Mailgun for WordPress plugin before 2.2.1 does not perform any capability or nonce check on an unauthenticated AJAX action that adds subscribers to the site owner's configured email service mailing lists, allowing unauthenticated attackers to enrol arbitrary email addresses into those lists using the owner's stored API credentials.
Affected products
- Mailgun for WordPress: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: Mailgun for WordPress 2.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14834 or the next vulnerability affects your stack