What’s Vulnerable › Vulnerabilities
CVE-2026-14840: YOP Poll < 7.0.6 - Unauthenticated Vote Restriction Bypass via IP Header Spoofing
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-08-26
- Weakness: CWE-290
Description
The YOP Poll WordPress plugin before 7.0.6 does not validate the connection's origin IP address and instead trusts client-controlled forwarding headers when enforcing its per-IP vote restriction, allowing unauthenticated attackers to bypass the vote limit and cast unlimited votes on a public poll.
Affected products
- YOP Poll: from 7.0.0 before 7.0.6 — fixed in 7.0.6
How to fix
Upgrade to a fixed version: YOP Poll 7.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14840 or the next vulnerability affects your stack