What’s Vulnerable › Vulnerabilities
CVE-2026-14841: King Addons for Elementor < 51.1.76 - Reflected XSS via Posts Grid Widget
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-02 · updated 2026-08-26
- Weakness: CWE-79
Description
The King Addons for Elementor WordPress plugin before 51.1.76 does not escape a user-supplied grid setting before reflecting it into an HTML attribute in an unauthenticated AJAX response, allowing attackers to execute arbitrary JavaScript in the browser of a visitor who is tricked into loading a crafted page.
Affected products
- King Addons for Elementor: before 51.1.76 — fixed in 51.1.76
How to fix
Upgrade to a fixed version: King Addons for Elementor 51.1.76. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14841 or the next vulnerability affects your stack