What’s Vulnerable › Vulnerabilities
CVE-2026-14854: WooCommerce Bookings < 3.11.0 - Unauthenticated Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-13
- Weakness: CWE-400
Description
The WooCommerce Bookings WordPress plugin before 3.11.0 does not limit a user-supplied value before using it to allocate memory in one of its unauthenticated AJAX actions, allowing unauthenticated attackers to exhaust server memory and cause a Denial of Service with a single request.
Affected products
- WooCommerce Bookings: before 3.11.0 — fixed in 3.11.0
How to fix
Upgrade to a fixed version: WooCommerce Bookings 3.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14854 or the next vulnerability affects your stack