What’s Vulnerable › Vulnerabilities
CVE-2026-14905: IBM DataPower Gateway XXE
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-15
- Weakness: CWE-611
Description
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to an XML external entity injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources.
Affected products
- IBM DataPower Gateway 11.0.0: from 10.5.0.0 before 10.5.0.23; from 10.6.0.0 before 10.6.0.11; from 10.6.1.0 before 11.0.0.3; from 11.0.0.0 before 11.0.0.3 — fixed in 10.5.0.23, 10.6.0.11, 11.0.0.3
How to fix
Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 10.5.0.23, 10.6.0.11, 11.0.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14905 or the next vulnerability affects your stack