What’s Vulnerable › Vulnerabilities
CVE-2026-14943: Password Protected < 2.8.4 - Unauthenticated Sensitive Information Exposure via REST API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-08-26
- Weakness: CWE-200
Description
The Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content WordPress plugin before 2.8.4 does not restrict REST API access to authenticated users when a specific option is enabled, allowing unauthenticated visitors to bypass the sitewide password gate and read otherwise-protected content and account identifiers via the REST API. This re-introduces a previously-fixed issue (CVE-2024-0437), which was patched in 2.6.7 and regressed in 2.6.8.
Affected products
- Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content: from 2.6.8 before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content 2.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14943 or the next vulnerability affects your stack