What’s Vulnerable › Vulnerabilities
CVE-2026-1496: Coverity CLI Authentication Bypass
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-639
Description
Vulnerable versions of Coverity Connect lack an error handler in the authentication logic for command line tooling that makes it vulnerable to an authentication bypass. A malicious actor with access to the /token API endpoint that either knows or guesses a valid username, can use this in a specially crafted HTTP request to bypass authentication. Successful exploitation allows the malicious actor to assume all roles and privileges granted to the valid user’s Coverity Connect account.
Affected products
- Black Duck Coverity: from 2024.3.0 before 2025.12.0 — fixed in 2025.12.0
How to fix
Upgrade to a fixed version: Black Duck Coverity 2025.12.0. Check the vendor advisory for mitigations.
References
- https://community.blackduck.com/s/article/Black-Duck-Security-Advisory-CVE-2026-1496
- https://community.blackduck.com/s/article/Instructions-on-how-to-block-token-endpoint-for-Coverity-Connect
- https://community.blackduck.com/s/article/WAF-IDS-IPS-Mitigation-Guidance
- https://github.com/blackduck-inc/Coverity-Usage-Log-Analyzer
Get alerted when CVE-2026-1496 or the next vulnerability affects your stack