What’s Vulnerable › Vulnerabilities
CVE-2026-14976: IBM WebSphere Application Server Liberty is affected by a remote code execution and path-segment injection vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-306
Description
IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 is affected by remote code execution with the collectiveController-1.0 feature enabled.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 26.0.0.9 — fixed in 26.0.0.9
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14976 or the next vulnerability affects your stack