What’s Vulnerable › Vulnerabilities
CVE-2026-15045: Wallet System for WooCommerce < 2.7.10 - Customer+ Checkout Price Manipulation via Unvalidated Wallet Amount
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-472
Description
The Wallet System for WooCommerce WordPress plugin before 2.7.10 does not validate a user-supplied wallet amount against the customer's actual stored balance during checkout, allowing authenticated customers to arbitrarily reduce their own order total, including down to zero, and complete checkout without paying the merchant.
Affected products
- Wallet System for WooCommerce: before 2.7.10 — fixed in 2.7.10
How to fix
Upgrade to a fixed version: Wallet System for WooCommerce 2.7.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15045 or the next vulnerability affects your stack