What’s Vulnerable › Vulnerabilities
CVE-2026-15057: IBM WebSphere Application Server Liberty is affected by a denial of service vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-787
Description
IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.7 is vulnerable to a denial of service due to uncontrolled heap allocation.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 26.0.0.8 — fixed in 26.0.0.8
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15057 or the next vulnerability affects your stack