What’s Vulnerable › Vulnerabilities
CVE-2026-15059: systemd-oomd: unprivileged users can terminate arbitrary processes
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-23
- Weakness: CWE-22
Description
Local unprivileged users can terminate arbitrary local processes via a systemd-oomd IPC API due to a missing path traversal validation.
Affected products
- systemd-oomd: from 250 before 261, 260.3, 259.7, 258.9 — fixed in 258.9, 259.7, 260.3, 261
How to fix
Upgrade to a fixed version: systemd-oomd 258.9, 259.7, 260.3, 261. Check the vendor advisory for mitigations.
References
- https://github.com/systemd/systemd/security/advisories/GHSA-652q-wxr6-h5j6
- https://github.com/systemd/systemd/security/advisories/GHSA-652q-wxr6-h5j6
Get alerted when CVE-2026-15059 or the next vulnerability affects your stack