What’s Vulnerable › Vulnerabilities
CVE-2026-15060: systemd-machined: unprivileged users can terminate arbitrary processes
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-23
- Weakness: CWE-284
Description
When systemd-machined >= v259 (or v258 with a custom `polkit` policy that allows `register-machine` access) is running on a desktop system, an unprivileged user logged in a desktop graphical session can kill arbitrary processes, even privileged ones. - versions older than v259 are not affected, unless unprivileged access is granted for the `register-machine` polkit action via a local, custom policy config file - versions older than v258 are not affected - unrelated to the systemd service manager (pid 1 or user session managers) - systemd-machined is not typically installed by default, and is typically in an optional, separate package (e.g.: systemd-container) - terminal-only or remote sessions (e.g.: ssh) are not affected
Affected products
- systemd-machined: from 259 before 262, 261.2, 260.4, 259.8, 258.10 — fixed in 258.10, 259.8, 260.4, 261.2, 262
How to fix
Upgrade to a fixed version: systemd-machined 258.10, 259.8, 260.4, 261.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15060 or the next vulnerability affects your stack