What’s Vulnerable › Vulnerabilities
CVE-2026-15064: IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by multiple vulnerabilities
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-09-23
- Weakness: CWE-444
Description
IBM WebSphere Application Server and IBM WebSphere Application Server - Liberty is vulnerable to HTTP Response Smuggling due to improper handling of non-standard HTTP version tokens.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.31; from 9.0.0.0 before 9.0.5.29; from 17.0.0.3 before 26.0.0.8 — fixed in 26.0.0.8, 8.5.5.31, 9.0.5.29
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.8, 8.5.5.31, 9.0.5.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15064 or the next vulnerability affects your stack