What’s Vulnerable › Vulnerabilities
CVE-2026-15166: Stack-based Buffer Overflow in Wireshark
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-121
Description
IEEE 802.11 protocol dissector crash in Wireshark 4.6.0 to 4.6.6 and 4.4.0 to 4.4.16 allows denial of service
Affected products
- Wireshark Foundation Wireshark: from 4.4.0 before 4.4.17; from 4.6.0 before 4.6.7 — fixed in 4.4.17, 4.6.7
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.4.17, 4.6.7. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/work_items/21391
- https://www.wireshark.org/security/wnpa-sec-2026-57.html
- https://gitlab.com/wireshark/wireshark/-/work_items/21391
Get alerted when CVE-2026-15166 or the next vulnerability affects your stack