What’s Vulnerable › Vulnerabilities
CVE-2026-15183: Input Validation Vulnerabilities in Snowflake Spark Connector
- Severity: critical (CVSS 9.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-89
Description
Multiple input validation vulnerabilities in the Snowflake Spark Connector (spark-snowflake) versions prior to 3.2.1 can allow attackers to exfiltrate OAuth client credentials, execute arbitrary SQL with the connector's Snowflake role, or redirect COPY operations to attacker-controlled storage. An attacker could exploit these vulnerabilities by supplying a crafted OAuth token request URL, placing malicious files in an ingestion pipeline, injecting SQL via staging options in a shared Spark environment , or issuing runtime SET commands in a shared Spark-SQL session to inject arbitrary SQL into the SnowflakeFallbackCatalog's option map, which executes under the cluster admin's JDBC credentials. Successful exploitation may result in credential theft, unauthorized access to Snowflake account data, or privilege escalation within connected infrastructure.
Affected products
- Snowflake Spark Connector: from 0.1.0 before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Snowflake Spark Connector 3.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15183 or the next vulnerability affects your stack