What’s Vulnerable › Vulnerabilities
CVE-2026-15205: Paymob for WooCommerce < 4.1.9 - Unauthenticated SQL Injection via Paymob Callback Pixel Lookup
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-26
- Weakness: CWE-89
Description
The Paymob for WooCommerce WordPress plugin before 4.1.9 does not properly sanitise a client-supplied identifier before using it in a SQL query within its public, unauthenticated payment callback, and performs this query before verifying the payment provider's HMAC signature. This allows unauthenticated attackers to perform SQL injection and read arbitrary data from the database — including user credentials and other secrets — through both in-band (reflected) and time-based blind extraction.
Affected products
- Paymob for WooCommerce: before 4.1.9 — fixed in 4.1.9
How to fix
Upgrade to a fixed version: Paymob for WooCommerce 4.1.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15205 or the next vulnerability affects your stack