What’s Vulnerable › Vulnerabilities
CVE-2026-15214: Subscriptions for WooCommerce < 2.0.1 - Subscriber+ Subscription Detail Disclosure via IDOR
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-08-26
- Weakness: CWE-639
Description
The Subscriptions for WooCommerce WordPress plugin before 2.0.1 does not verify that the requester owns the subscription being viewed before rendering its details, allowing any authenticated customer to read another customer's subscription information (the subscribed product, status, and dates) by supplying that subscription's ID.
Affected products
- Subscriptions for WooCommerce: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Subscriptions for WooCommerce 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15214 or the next vulnerability affects your stack