What’s Vulnerable › Vulnerabilities
CVE-2026-15215: Subscriptions for WooCommerce < 2.0.1 - Shop Manager+ Arbitrary Plugin Installation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-08-26
- Weakness: CWE-269
Description
The Subscriptions for WooCommerce WordPress plugin before 2.0.1 does not verify the user's capability before installing and activating a Subscriptions for WooCommerce WordPress plugin before 2.0.1 from a user-supplied slug through a nonce-protected AJAX action, allowing users with the Shop Manager role (who lack Subscriptions for WooCommerce WordPress plugin before 2.0.1-management capabilities) to install and activate arbitrary Subscriptions for WooCommerce WordPress plugin before 2.0.1, resulting in remote code execution.
Affected products
- Subscriptions for WooCommerce: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Subscriptions for WooCommerce 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15215 or the next vulnerability affects your stack