What’s Vulnerable › Vulnerabilities
CVE-2026-15233: Nested Pages < 3.2.15 - Editor+ Stored XSS via Post Title
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-04 · updated 2026-08-26
- Weakness: CWE-79
Description
The Nested Pages WordPress plugin before 3.2.15 does not properly escape post titles before outputting them into HTML attributes on an administrative listing screen, allowing users with the Editor role (or Contributor/Author when the Nested Pages WordPress plugin before 3.2.15 is enabled for the post type) to inject arbitrary JavaScript that executes in the session of any higher-privileged user who views that screen.
Affected products
- Nested Pages: before 3.2.15 — fixed in 3.2.15
How to fix
Upgrade to a fixed version: Nested Pages 3.2.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15233 or the next vulnerability affects your stack