What’s Vulnerable › Vulnerabilities
CVE-2026-1524: Auth misconfiguration when multiple providers enabled
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-08-28
- Weakness: CWE-287
Description
An edgecase in SSO implementation in Neo4j Enterprise edition versions prior to version 2026.02 can lead to unauthorised access under the following conditions: If a neo4j admin configures two or more OIDC providers AND configures one or more of them to be an authorization provider AND configures one or more of them to be authentication-only, then those that are authentication-only will also provide authorization. This edgecase becomes a security problem only if the authentication-only provider contains groups which have higher privileges than provided by the intended (configured) authorization provider. When using multiple plugins for authentication and authorisation, prior to the fix the issue could lead to a plugin configured to provide only authentication or authorisation capabilities erroneously providing both capabilities. We recommend upgrading to versions 2026.02 (or 5.26.22) where the issue is fixed.
Affected products
- Neo4j: before 5.26.22; from 2025.01.0 before 2026.02.0 — fixed in 2026.02.0, 5.26.22
How to fix
Upgrade to a fixed version: Neo4j 2026.02.0, 5.26.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-1524 or the next vulnerability affects your stack