What’s Vulnerable › Vulnerabilities
CVE-2026-15254: Simply Schedule Appointments < 1.6.12.11 - Contributor+ Sensitive Data Disclosure via Admin Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-08-26
- Weakness: CWE-863
Description
The Simply Schedule Appointments WordPress plugin before 1.6.12.11 does not perform a capability check on an administrative appointment-listing shortcode, and its per-user result scoping fails open for non-staff users, allowing users with the Contributor role and above to disclose all customers' appointment records, including names, email addresses, phone numbers and notes, across the whole site.
Affected products
- Simply Schedule Appointments: before 1.6.12.11 — fixed in 1.6.12.11
How to fix
Upgrade to a fixed version: Simply Schedule Appointments 1.6.12.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15254 or the next vulnerability affects your stack