What’s Vulnerable › Vulnerabilities
CVE-2026-15314: Authenticated Denial-of-Service Vulnerability in TP-Link Tapo P110
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-04 · updated 2026-10-24
- Weakness: CWE-120
Description
Tapo P110 v1 smart Wi-Fi Plug contains an improper boundary validation vulnerability in the handling of authenticated HTTP request bodies due to insufficient input validation before memory copy operations. This may lead to buffer overflow condition, causing the web service process to crash. Successful exploitation may cause the web service process to stop responding or restart, resulting in a denial-of-service condition.
Affected products
- TP-Link Systems Inc. P110 v1: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. P110 v1 1.1.4. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/tapo-p110/v1/#Firmware-Release-Notes
- https://www.tp-link.com/us/support/download/tapo-p110/v1/#Firmware-Release-Notes
- https://www.tp-link.com/us/support/faq/5220/
Get alerted when CVE-2026-15314 or the next vulnerability affects your stack