What’s Vulnerable › Vulnerabilities
CVE-2026-15316: Denial-of-Service via Oversized Encrypted Credential Input in TP-Link Tapo C200
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-10-22
- Weakness: CWE-20
Description
An improper input validation vulnerability in the configuration service for processing encrypted credential data has been identified in Tapo C200 v5. An attacker can send oversized crypted ciphertext values that may trigger exception handling failures, due to insufficient validation, causing the affected device to crash or restart. Successful exploitation may temporarily disrupt HTTPS management and monitoring functionality, resulting in a denial-of-service (DoS) condition until the service recovers.
Affected products
- TP-Link Systems Inc. Tapo C200 v5: before 1.4.6 — fixed in 1.4.6
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Tapo C200 v5 1.4.6. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/tapo-c200/v5/
- https://www.tp-link.com/us/support/download/tapo-c200/v5/
- https://www.tp-link.com/us/support/faq/5248/
Get alerted when CVE-2026-15316 or the next vulnerability affects your stack