What’s Vulnerable › Vulnerabilities
CVE-2026-15321: MyEMS Admin Backend svg.py on_post cross site scripting
- Severity: low (CVSS 2.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-07-10
- Weakness: CWE-79
Description
A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.
Affected products
- MyEMS: 6.0, 6.1, 6.2, 6.3, 6.4.0
References
- https://github.com/MyEMS/myems/
- https://github.com/MyEMS/myems/commit/4a97edfbd786c779d0322054833b21ddf54d5b06
- https://github.com/MyEMS/myems/issues/412
- https://github.com/MyEMS/myems/releases/tag/v6.5.0
- https://vuldb.com/cve/CVE-2026-15321
- https://vuldb.com/submit/853060
- https://vuldb.com/vuln/377263
- https://vuldb.com/vuln/377263/cti
- https://vuldb.com/submit/853060
Get alerted when CVE-2026-15321 or the next vulnerability affects your stack