What’s Vulnerable › Vulnerabilities
CVE-2026-15388: Cookie Consent < 0.0.10 - Subscriber+ Consent Settings Update and Consent Log Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-08-26
- Weakness: CWE-863
Description
The Cookie Consent WordPress plugin before 0.0.10 does not correctly enforce its intended administrator-only capability check on its consent-settings REST routes, so they fall back to an authentication-only gate, allowing any authenticated user such as a subscriber to update the Cookie Consent WordPress plugin before 0.0.10's consent settings and, on sites connected to the vendor's paid plan, read stored visitor consent logs.
Affected products
- Cookie Consent: before 0.0.10 — fixed in 0.0.10
How to fix
Upgrade to a fixed version: Cookie Consent 0.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-15388 or the next vulnerability affects your stack