What’s Vulnerable › Vulnerabilities

CVE-2026-15423: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.0 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed an authenticated user with developer-role permissions to execute CI/CD pipelines on a protected branch without the required push permissions due to improper authorization in pipeline reference validation.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.6, 19.1.4, 19.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-15423 or the next vulnerability affects your stack