What’s Vulnerable › Vulnerabilities
CVE-2026-15429: Privilege Escalation via Improper Input Sanitization in TP-Link Archer VX1800v
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-93
Description
A privilege escalation vulnerability exists in the HTTP authentication component in Archer VX1800v v1. Improper handling of user-controlled input may allow newline characters to be injected into internally constructed configuration data. An authenticated user with sufficient privileges may be able to modify account settings and gain elevated administrative privileges.
Affected products
- TP-Link Systems Inc. Archer VX1800v v1: before 0.16.0; 2.0.0 — fixed in 0.16.0
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer VX1800v v1 0.16.0. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-vx1800v/#Firmware
- https://www.tp-link.com/us/support/faq/5189/
Get alerted when CVE-2026-15429 or the next vulnerability affects your stack